Paperwork Uploading Issues

Incident Report for Connect

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 08:42 EST

Investigating

We are currently investigating issues with paperwork upload and working with our vendors. We will keep you updated every 30 minutes as we look to resolve the issue.
Posted Feb 11, 2026 - 07:40 EST
This incident affected: Connect (Order Entry, Carrier Rate Confirmations).