Rate Confirmation

Incident Report for Connect

Resolved

This incident has been resolved.
Posted Sep 20, 2025 - 15:42 EDT

Monitoring

We are continuing to work with and monitor our vendor(s) situation.
Posted Sep 19, 2025 - 15:01 EDT

Investigating

Our rate confirmation vendor is experiencing issues again we have fallen back to our backup option. We are engaged with the vendor again as to why this is happening on repeated days.
Posted Sep 19, 2025 - 12:16 EDT
This incident affected: Connect (Carrier Rate Confirmations).