Issue with 3rd Party Vendor Performance

Incident Report for Connect

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 09:44 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 09:43 EST

Update

We have identified more services that are being impacted, we are working with Cloudflare to see when the resolution will happen
Posted Nov 18, 2025 - 09:14 EST

Investigating

Cloudflare, a major internet backbone provider, is having issues around the global and company's who rely on them are having issues. Currently none of our in house systems are reliant on them but numerous vendors are like DAT etc. We are monitoring the situation and checking our vendor status pages. We will update you as we get information.
Posted Nov 18, 2025 - 08:41 EST
This incident affected: ThirdParty Integrations (DAT, ITS, Twilio, PC Miler, Macropoint).