Logging In Issues

Incident Report for Connect

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 21:09 EST

Monitoring

We are monitoring the situations where people are having problems with logging into Connect and/or logging out. Please continue to reach out to Agent Support or HelpDesk. We believe we resolved the issue but please continue to communicate to us. If you haven't please close browser and retry if that doesn't work let us know.
Posted Feb 17, 2026 - 09:01 EST
This incident affected: Connect (Order Entry).